2013-12-05 15:45:29Morris

[UVA][Easy] 12650 - Dangerous Dive

SampleInput

5 3

3 1 5

6 6

6 1 3 2 5 4

SampleOutput

2 4

*







單純的標記問題,給犧牲名單,輸出剩餘存活名單。

#include <stdio.h>
#include <string.h>
int main() {
    int N, R;
    int i, j;
    char mark[10005];
    while(scanf("%d %d", &N, &R) == 2) {
        memset(mark, 0, sizeof(mark));
        while(R--)
            scanf("%d", &i), mark[i] = 1;
        for(i = 1, j = 0; i <= N; i++) {
            if(mark[i] == 0) {
                j++;
                printf("%d ", i);
            }
        }
        if(!j)    putchar('*');
        puts("");
    }
    return 0;
}