2013-07-12 08:16:00Morris

[UVA] 1111 - Trash Removal

Allied Chute Manufacturers is a company that builds trash chutes. A trash chute is a hollow tube installed in buildings so that trash dropped in at the top will fall down and be collected in the basement. Designing trash chutes is actually highly nontrivial. Depending on what kind of trash people are expected to drop into them, the trash chute needs to have an appropriate size. And since the cost of manufacturing a trash chute is proportional to its size, the company always would like to build a chute that is as small as possible. Choosing the right size can be tough though.

We will consider a 2-dimensional simplification of the chute design problem. A trash chute points straight down and has a constant width. Objects that will be dropped into the trash chute are modeled as polygons. Before an object is dropped into the chute it can be rotated so as to provide an optimal fit. Once dropped, it will travel on a straight path downwards and will not rotate in flight. The following figure shows how an object is first rotated so it fits into the trash chute.

epsfbox{p5138.eps}

Your task is to compute the smallest chute width that will allow a given polygon to pass through.

Input 

The input contains several test cases. Each test case starts with a line containing an integer n (3$ le$n$ le$100), the number of points in the polygon that models the trash item.

The next n lines then contain pairs of integers xi and yi (0$ le$xi, yi$ le$104), giving the coordinates of the polygon vertices in order. All points in one test case are guaranteed to be mutually distinct and the polygon sides will never intersect. (Technically, there is one inevitable exception of two neighboring sides sharing their common vertex. Of course, this is not considered an intersection.)

The last test case is followed by a line containing a single zero.

Output 

For each test case, display its case number followed by the width of the smallest trash chute through which it can be dropped. Display the minimum width with exactly two digits to the right of the decimal point, rounding up to the nearest multiple of 1/100. Answers within 1/100 of the correct rounded answer will be accepted.

Follow the format of the sample output.

Sample Input 

3
0 0
3 0
0 4
4
0 10
10 0
20 10
10 20
0

Sample Output 

Case 1: 2.40
Case 2: 14.15


題目描述:
給定一個垃圾的多邊形,問丟入垃圾桶的最小寬度為何。
題目解法:

可以使用凸包,會比較快一點。
這題需要點線距的公式 ax+by+c = 0, 對於點 (x, y), 距離是 |ax+by+c|/sqrt(a*a+b*b)

如果不使用凸包,窮舉任兩點拉一直線,計算兩側的最大寬度加起來。
然後取最小值。O(n^3)

用凸包則是 O(nlogn + n*n)

#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define eps 1e-8
struct Pt {
double x, y;
bool operator<(const Pt &A) const {
if(fabs(x-A.x) > eps)
return x < A.x;
return y < A.y;
}
};
double cross(Pt o, Pt a, Pt b) {
return (a.x-o.x)*(b.y-o.y)-(a.y-o.y)*(b.x-o.x);
}
int monotone(Pt p[], int n, Pt ch[]) {
sort(p, p+n);
int i, m = 0, t;
for(i = 0; i < n; i++) {
while(m >= 2 && cross(ch[m-2], ch[m-1], p[i]) <= 0)
m--;
ch[m++] = p[i];
}
for(i = n-1, t = m+1; i >= 0; i--) {
while(m >= t && cross(ch[m-2], ch[m-1], p[i]) <= 0)
m--;
ch[m++] = p[i];
}
return m-1;
}
int main() {
/*freopen("in.txt", "r+t", stdin);
freopen("out2.txt", "w+t", stdout);*/
int n, m, i, j, k;
int cases = 0;
Pt D[505], ch[505];
while(scanf("%d", &n) == 1 && n) {
for(i = 0; i < n; i++)
scanf("%lf %lf", &D[i].x, &D[i].y);
m = monotone(D, n, ch);
double ret = 1e+60;
for(i = 0, j = m-1; i < m; j = i, i++) {
double na = -(ch[i].y-ch[j].y), nb = ch[i].x-ch[j].x;
double c = -(na*ch[i].x+nb*ch[i].y);
double len = hypot(na, nb);
double farth = 0;
for(k = 0; k < n; k++)
farth = max(farth, fabs(na*D[k].x+nb*D[k].y+c)/(len));
ret = min(ret, farth);
}
printf("Case %d: %.2lf\n", ++cases, ret);
}
return 0;
}


sexe videos 2018-06-09 22:59:20

Thank you....

sitkp 2017-10-02 21:06:16

Wanderful thank

msmmo 2017-10-02 21:05:15

thanks you