2013-07-12 08:06:49Morris

[UVA][并查集] 1160 - X-Plosives

X-Plosives

 

A secret service developed a new kind of explosive that attain its volatile property only when a specific association of products occurs. Each product is a mix of two different simple compounds, to which we call a binding pair. If N>2, then mixing N different binding pairs containing N simple compounds creates a powerful explosive. For example, the binding pairs A+B, B+C, A+C (three pairs, three compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.

 

You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in the same room an explosive association. So, after placing a set of pairs, if you receive one pair that might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you must accept it.

 

An example. Let’s assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G, F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds). Finally, you would accept the last pair, F+H.

 

Compute the number of refusals given a sequence of binding pairs.

 

Input

The input will contain several test cases, each of them as described below. Consecutive test cases are separated by a single blank line.

Instead of letters we will use integers to represent compounds. The input contains several lines. Each line (except the last) consists of two integers (each integer lies between 0 and 105) separated by a single space, representing a binding pair. The input ends in a line with the number –1. You may assume that no repeated binding pairs appears in the input.

 

Output

For each test case, a single line with the number of refusals.

 

Sample Input

1 2

3 4

3 5

3 1

2 3

4 1

2 6

6 5

-1

 

Sample Output

3



題目說明:
如果有 N 個不同的化合物,同時存在 N 個混合物,她們將會爆炸。感覺起來接近於連鎖反應,呈現一個環狀反應。依序將混合物搬上車,如果搬上去前發現會發生爆炸,那麼就不搬運。問有多少混合物沒有辦法搬上車。

題目解法:
使用并查集,確認是否有環。

#include <stdio.h>
int p[100005], rank[100005];
int findp(int x) {
    return p[x] == x ? x : (p[x]=findp(p[x]));
}
int joint(int x, int y) {
    x = findp(x), y = findp(y);
    if(x == y)
        return 0;
    if(rank[x] > rank[y])
        rank[x] += rank[y], p[y] = x;
    else
        rank[y] += rank[x], p[x] = y;
    return 1;
}
int main() {
    int x, y, i;
    while(true) {
        if(scanf("%d %d", &x, &y) != 2)
            break;
        for(i = 0; i < 100005; i++)
            p[i] = i, rank[i] = 1;
        int ret = 0, flag;
        flag = joint(x, y);
        if(!flag)   ret++;
        while(scanf("%d", &x) == 1 && x >= 0) {
            scanf("%d", &y);
            flag = joint(x, y);
            if(!flag)   ret++;
        }
        printf("%d\n", ret);
    }
    return 0;
}