2013-01-01 09:22:47Morris

[UVA][greedy+并查集] 1316 - Supermarket

A supermarket has a set Prod of products on sale. It earns a profit px for each product x in Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell from Prod such that the selling of each product x in Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is . An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,pa=(50,2), (pb,pb=(10,1), (pc,pc=(20,2), and (pd,pd=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input 

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output 

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input 

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8
2
5 20  50 10

Sample Output 

80
185
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

對價值作排序(由大到小),使用 disjoint set 去完成模擬的動作,
盡可能放在靠近 deadline 的位置(也就是盡可能靠右)。
disjoint set 模擬兩區間(使用過)的合併,然後多紀錄一個最左邊的區間 l,
到時候查詢這個最左邊 l-1 放置這個選項,如果 l-1 <= 0 則棄置。

#include <stdio.h>
#include <algorithm>
using namespace std;
struct task {
    int d, p;
};
bool cmp(task a, task b) {
    return a.p > b.p;
}
int p[10005], r[10005], inter[10005];
void init(int n) {
    for(int i = 0; i <= n; i++)
        p[i] = i, r[i] = 1, inter[i] = i;
}
int findp(int x) {
    return p[x] == x ? x : (p[x]=findp(p[x]));
}
int joint(int x, int y) {
    x = findp(x), y = findp(y);
    if(x != y) {
        if(r[x] > r[y]) {
            p[y] = x, r[x] += r[y];
            inter[x] = min(inter[x], inter[y]);
        } else {
            p[x] = y, r[y] += r[x];
            inter[y] = min(inter[x], inter[y]);
        }
        return 1;
    }
    return 0;
}
int main() {
    int n, i, x, y;
    int sche[10005];
    while(scanf("%d", &n) == 1) {
        task A[10005];
        int day = 1, ans = 0;
        for(i = 0; i < n; i++) {
            scanf("%d %d", &A[i].p, &A[i].d);
            day = max(day, A[i].d);
        }
        day++;
        for(i = 1; i <= day; i++)
            sche[i] = 0;
        sort(A, A+n, cmp);
        init(day);
        for(i = 0; i < n; i++) {
            if(sche[A[i].d] == 0) {
                x = y = A[i].d;
                if(sche[x+1])
                    x++;
            } else {
                x = findp(A[i].d);
                y = inter[x]-1;
                if(!y)  continue;
            }
            sche[y] = i+1;
            ans += A[i].p;
            joint(x, y);
            if(y-1 > 0 && sche[y-1])
                joint(y-1, y);
        }
        printf("%d\n", ans);
    }
    return 0;
}
/*
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8
2
5 20  50 10
*/