[UVA][DAG] 103 - Stacking Boxes
Stacking Boxes
Stacking Boxes |
Background
Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions and analyzing the topology of an n-dimensional hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.
The Problem
Consider an n-dimensional ``box'' given by its dimensions. In two
dimensions the box (2,3) might represent a box with length 2 units and
width 3 units. In three dimensions the box (4,8,9) can represent a box
(length, width, and height). In 6 dimensions it
is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can
analyze properties of the box such as the sum of its dimensions.
In this problem you will
analyze a property of a group of n-dimensional boxes.
You are to determine the longest nesting string of boxes, that
is a sequence of boxes such that each box
nests in box
(
.
A box D = ( )
nests in a box E = (
)
if there is some rearrangement of the
such that when rearranged
each dimension is less than the corresponding dimension in box E.
This loosely corresponds to turning box D to see if it will fit in box
E. However, since any rearrangement suffices, box D can be contorted, not just
turned (see examples below).
For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box E = (2,10,6,8) since no rearrangement of D results in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.
Formally, we define nesting as follows:
box D = ( ) nests in box E = (
) if there is a permutation
of
such that
(
) ``fits'' in (
) i.e., if
for all
.
The Input
The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxes k in the sequence followed by the dimensionality of the boxes, n (on the same line.)
This line is followed by k lines, one line per box
with the n measurements of each box on
one line separated by one or more spaces. The line in the
sequence (
) gives the measurements for the
box.
There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of the k boxes determine the longest nesting string and the length of that nesting string (the number of boxes in the string).
In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.
The Output
For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost'' box of the nesting string should be listed first, the next box (if there is one) should be listed second, etc.
The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).
If there is more than one longest nesting string then any one of them can be output.
Sample Input
5 2 3 7 8 10 5 2 9 11 21 18 8 6 5 2 20 1 30 10 23 15 7 9 11 3 40 50 34 24 14 4 9 10 11 12 13 14 31 4 18 8 27 17 44 32 13 19 41 19 1 2 3 4 5 6 80 37 47 18 21 9
Sample Output
5 3 1 2 4 5 4 7 2 5 6
沒考慮效率問題, 隨便做
#include <stdio.h>
#include <algorithm>
using namespace std;
int main() {
int k, n;
int A[30][10];
while(scanf("%d %d", &k, &n) == 2) {
int i, j, l;
int map[30][30] = {}, bmap[30][30] = {};
for(i = 0; i < k; i++) {
for(j = 0; j < n; j++)
scanf("%d", &A[i][j]);
sort(A[i], A[i]+n);
}
int indeg[30] = {};
for(i = 0; i < k; i++) {
for(j = 0; j < k; j++) {
for(l = 0; l < n; l++) {
if(A[i][l] >= A[j][l])
break;
}
if(l == n) {
map[i][j] = 1, indeg[j]++, bmap[j][i] = 1;
} else
map[i][j] = 0, bmap[j][i] = 0;
}
}
int dp[30] = {}, sour[30] = {}, used[30] = {};
while(1) {
for(i = 0; i < k; i++) {
if(indeg[i] == 0 && used[i] == 0) {
int mm = -1, mi = -1;
for(j = 0; j < k; j++) {
if(bmap[i][j] == 1) {
if(dp[j] > mm)
mm = dp[j], mi = j;
}
}
mm++;
used[i] = 1, dp[i] = mm;
sour[i] = mi;
for(j = 0; j < k; j++) {
if(map[i][j] == 1 && used[j] == 0)
indeg[j]--;
}
break;
}
}
if(i == k) break;
}
int mm = -1, mi = -1;
for(i = 0; i < k; i++)
if(dp[i] > mm)
mm = dp[i], mi = i;
printf("%d\n", mm+1);
int ans[30], at = -1;
do {
ans[++at] = mi;
if(dp[mi] == 0) break;
mi = sour[mi];
} while(1);
for(i = at; i >= 0; i--)
printf("%s%d", i != at ? " " : "", ans[i]+1);
puts("");
}
return 0;
}