[UVA][幾何] 438 - The Circumference of the Circle
The Circumference of the Circle
The Circumference of the Circle |
To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?
You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.
Input Specification
The input file will contain one or more test cases. Each test case consists of one line containing six real numbers , representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.
Output Specification
For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of is approximately 3.141592653589793.
Sample Input
0.0 -0.5 0.5 0.0 0.0 0.5 0.0 0.0 0.0 1.0 1.0 1.0 5.0 5.0 5.0 7.0 4.0 6.0 0.0 0.0 -1.0 7.0 7.0 7.0 50.0 50.0 50.0 70.0 40.0 60.0 0.0 0.0 10.0 0.0 20.0 1.0 0.0 -500000.0 500000.0 0.0 0.0 500000.0
Sample Output
3.14 4.44 6.28 31.42 62.83 632.24 3141592.65
題目 : 給三點求外接圓周長
以前用海龍公式求面積, 現在用外積求面積,
不過核心公式還是 三角形面積 = a*b*c/(4R)
#include <stdio.h>
#include <math.h>
struct Point {
double x, y;
};
double cross(Point &o, Point &a, Point &b) {
return (a.x-o.x)*(b.y-o.y) - (a.y-o.y)*(b.x-o.x);
}
double dist(Point &a, Point &b) {
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main() {
Point a, b, c;
double R, area, pi = acos(-1);
while(scanf("%lf %lf", &a.x, &a.y) == 2) {
scanf("%lf %lf", &b.x, &b.y);
scanf("%lf %lf", &c.x, &c.y);
area = fabs(cross(a, b, c))/2;
R = dist(a, b)*dist(b, c)*dist(c, a)/4.0/area;
printf("%.2lf\n", 2*pi*R);
}
return 0;
}