2013-11-11 09:10:24Morris
[POJ][單調堆] 2559 - Largest Rectangle in a Histogram
Description
A histogram
is a polygon composed of a sequence of rectangles aligned at a common
base line. The rectangles have equal widths but may have different
heights. For example, the figure on the left shows the histogram that
consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in
units where 1 is the width of the rectangles:
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For
each test case output on a single line the area of the largest
rectangle in the specified histogram. Remember that this rectangle must
be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
Sample Output
8 4000
Hint
Huge input, scanf is recommended.
Source
Ulm Local 2003
維護一個單調堆,裡頭高度由小到大排。
插入時,記錄一個最小的索引值。
#include <stdio.h>
#include <stack>
#include <algorithm>
using namespace std;
long long solve(int n, int h[]) {
long long ret = 0;
int i, height;
stack< pair<int, int> > stk;// <height, position>
pair<int, int> e;
stk.push(make_pair(-1, 0));
h[n] = 0;// visual height.
for(i = 0; i <= n; i++) {
height = h[i];
e = make_pair(height, i);
while(height < stk.top().first) {
e = stk.top(), stk.pop();
ret = max(ret, (long long)(i - e.second) * e.first);
}
if(height > stk.top().first)
stk.push(make_pair(height, e.second));
}
return ret;
}
int main() {
int n, h[100005], i;
while(scanf("%d", &n) == 1 && n) {
for(i = 0; i < n; i++)
scanf("%d", &h[i]);
printf("%I64d\n", solve(n, h));
}
return 0;
}
維護一個單調堆,裡頭高度由小到大排。
插入時,記錄一個最小的索引值。
#include <stdio.h>
#include <stack>
#include <algorithm>
using namespace std;
long long solve(int n, int h[]) {
long long ret = 0;
int i, height;
stack< pair<int, int> > stk;// <height, position>
pair<int, int> e;
stk.push(make_pair(-1, 0));
h[n] = 0;// visual height.
for(i = 0; i <= n; i++) {
height = h[i];
e = make_pair(height, i);
while(height < stk.top().first) {
e = stk.top(), stk.pop();
ret = max(ret, (long long)(i - e.second) * e.first);
}
if(height > stk.top().first)
stk.push(make_pair(height, e.second));
}
return ret;
}
int main() {
int n, h[100005], i;
while(scanf("%d", &n) == 1 && n) {
for(i = 0; i < n; i++)
scanf("%d", &h[i]);
printf("%I64d\n", solve(n, h));
}
return 0;
}