[UVA][dp] 10604 - Chemical Reaction
In a chemist’s lab, there are several types of chemicals in tubes. The chemist wants to mix all these chemicals together, two chemicals at a time. Whenever two chemicals are mixed, some heat is generated and released into the air and the mixed chemical is a known chemical of possibly other type than the original two. The resulting chemical type and the amount of heats emitted can looked up in the chemical mixture table.
Chemicals |
1 |
2 |
3 |
|||
Resulting chemical type |
Heats emmited |
Resulting chemical type |
Heats emmited |
Resulting chemical type |
Heats emmited |
|
1 |
1 |
0 |
3 |
-10 |
3 |
3000 |
2 |
3 |
-10 |
2 |
0 |
1 |
-500 |
3 |
3 |
3000 |
1 |
-500 |
3 |
0 |
For example, in the above chemical mixture table, there are three types of chemicals: 1, 2, and 3. If you mix chemicals 1 and 3, they produce +3000 units of heat and turn into chemical 3. Sometimes, the heat generated can be negative. For instance, you can mix 2 and 3 and they turn into chemical 1 and in the meantime, cool down the lab by 500 units of heat. Since the chemist lacks funding to buy necessary equipments to protect himself from the heat generated, it is utmost important to find a way to mix all the chemicals together that produces the least total heat, regardless of the final chemical type. For example, suppose the lab has four tubes containing chemicals of types 1, 2, 2, and 3. If the chemicals are mixed in the parenthesize order of ((1 2) (2 3)), it will produce (–10)+ (-500)+(3000) = 2490 units of heat. However, if the chemicals are mixed in the (2 (1 (2 3))) order, it will produce (-500)+0+(-10)= -510 units of heat, which is also the least total heat possible.
Input
The first line of input file consists of a single number denoting the number of test cases in the file. There is a single line containing a ‘/’ character separating two consecutive test cases. The end of the file is marked with a line containing a ‘.’ For each test case, the first line contains an integer number m (1≤m≤6) denoting the number chemical types. Therefore, the chemicals are indexed from 1 up to at most 6. The next mxm lines give the chemical mixture table entries in the row-major order. Each line contains the new resulting chemical type and the amount of energy emitted. After the table entries is a line with a single number k (2≤k≤10) denoting number of tubes in the lab. The next line then contains k integers in the range of 1 and m, separated by blank spaces, denoting the types of chemicals in those k tubes.
Output
For each test case, output the least total heat possible on a single line.
Sample Input |
Sample Output |
2 3 1 0 3 -10 3 3000 3 -10 2 0 1 -500 3 3000 1 -500 3 0 4 1 2 2 3 / 3 1 0 3 500 3 -250 3 500 2 0 1 100 3 -250 1 100 3 0 6 1 1 1 2 2 3 . |
-510 -650 |
Problem translation: LitteJohn
Problem solution: LitteJohn
題目描述:
有 n (n <= 6)種化合物,兩兩可以化合成另一種化合物(一定也在給定的 n 種中),
化合時會放熱,而誰放入誰的反應不見得會一樣?(因此得到 WA)。
給定化學反應表,以及一開始每種化合物的分量(總分量 <= 10)
問最後只剩下一份量的化合物時,放熱最少為何。
題目解法:
狀態 dp[11][11][11][11][11][11] => 10^6
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int n, m;
int result[6][6], heat[6][6];
int dp[11][11][11][11][11][11];
char used[11][11][11][11][11][11];
int dfs(int argv[]) {
if(used[argv[0]][argv[1]][argv[2]][argv[3]][argv[4]][argv[5]])
return dp[argv[0]][argv[1]][argv[2]][argv[3]][argv[4]][argv[5]];
used[argv[0]][argv[1]][argv[2]][argv[3]][argv[4]][argv[5]] = 1;
int &ret = dp[argv[0]][argv[1]][argv[2]][argv[3]][argv[4]][argv[5]];
int i, j, k;
ret = 0xfffffff;
if(argv[0]+argv[1]+argv[2]+argv[3]+argv[4]+argv[5] == 1) {
ret = 0;
return ret;
}
for(i = 0; i < n; i++) {
for(j = 0; j < n; j++) {
if(j == i) {
if(argv[i] >= 2) {
argv[i] -= 2, argv[result[i][i]]++;
ret = min(ret, heat[i][i]+dfs(argv));
argv[i] += 2, argv[result[i][i]]--;
}
} else {
if(argv[i] && argv[j]) {
argv[i] --, argv[j]--, argv[result[i][j]]++;
ret = min(ret, heat[i][j]+dfs(argv));
argv[i] ++, argv[j]++, argv[result[i][j]]--;
}
}
}
}
return ret;
}
int main() {
int testcase;
int i, j, k;
scanf("%d", &testcase);
while(testcase--) {
scanf("%d", &n);
for(i = 0; i < n; i++)
for(j = 0; j < n; j++)
scanf("%d %d", &result[i][j], &heat[i][j]), result[i][j]--;
memset(used, 0, sizeof(used));
scanf("%d", &m);
int x, argv[6] = {};
for(i = 0; i < m; i++) {
scanf("%d", &x), x--;
argv[x]++;
}
printf("%d\n", dfs(argv));
scanf("%*s");
}
return 0;
}