2013-06-14 20:00:15Morris

[UVA][greedy] 668 - Parliament


  Parliament 

New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.


You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.

Input 

The first line of the input is an integer M, then a blank line followed by M datasets. There is a blank line between datasets. Each dataset contains a single integer N ( $5 le N le 1000$).

Output 

For each dataset, write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces. Print a blank line between datasets.

Sample Input 

1

31

Sample Output 

2 3 5 6 7 8



Miguel Revilla
2000-05-22

題目希望每天都不一樣的數字,且越多越好,但不可為一。總和為 N

解法是依據一種 greedy 方式去執行。
從 2+3+4 ... 直到下一個超過 N,其數值往前填加。
最後若發生 1 個存在則丟入最後一個數字。



#include <stdio.h>

int main() {
    int testcase, n;
    scanf("%d", &testcase);
    while(testcase--) {
        scanf("%d", &n);
        int sum = 0, i, j;
        int ans[1005], at = 0;
        for(i = 2; ; i++) {
            if(sum + i > n) {
                int tmp = n-sum;
                for(j = at-1; j >= 0 && tmp; j--)
                    ans[j]++, tmp--;
                if(tmp)
                    ans[at-1]++;
                break;
            }
            ans[at++] = i;
            sum += i;
        }
        for(i = 0; i < at; i++) {
            if(i)   putchar(' ');
            printf("%d", ans[i]);
        }
        puts("");
        if(testcase)    puts("");
    }
    return 0;
}