[UVA][SSSP] 523 - Minimum Transport Cost
Minimum Transport Cost
Minimum Transport Cost |
There are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
- 1.
- the cost of the transportation on the path between these cities, and
- 2.
- a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.
You must write a program to find the route which has the minimum cost.
Input
The first line of the input is an integer M, then a blank line followed by M datasets. There is a blank line between datasets. The data of path cost, city tax, source and destination cities are given in each dataset, which is of the form:
where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and city g to city h.
Output
For each datase, you must output the sequence of cities passed by and the total cost, which is of the form:
From c to d :
Path: c->c1->->ck->d
Total cost :
From e to f :
Path: e->e1->->ek->f
Total cost :
Print a blank line between datasets,
Sample Input
1 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4
Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
Miguel A. Revilla
1999-01-11
單源最短路徑,這題的輸出很折騰人的,有看沒有懂。
tricky input:
1 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1
1 1
tricky output:
From 1 to 1 :
Path: 1-->1
Total cost : 0
#include <stdio.h>
#include <sstream>
#include <iostream>
#include <queue>
using namespace std;
int main() {
int t;
char s[505];
int g[505][505], gv[505];
scanf("%d", &t);
while(getchar() != '\n');
while(getchar() != '\n');
while(t--) {
gets(s);
stringstream sin(s);
int n = 1, x, y, i, j;
while(sin >> g[1][n])
n++;
n--;
for(i = 2; i <= n; i++)
for(j = 1; j <= n; j++)
scanf("%d", &g[i][j]);
for(i = 1; i <= n; i++)
scanf("%d", &gv[i]);
while(getchar() != '\n');
int pflag = 0;
while(gets(s) && s[0]) {
if(pflag) puts("");
pflag = 1;
int st, ed;
int dis[505] = {}, used[505] = {}, prev[505];
sscanf(s, "%d %d", &st, &ed);
for(i = 1; i <= n; i++)
dis[i] = 0xfffffff;
dis[st] = 0;
queue<int> Q;
Q.push(st);
while(!Q.empty()) {
x = Q.front(), Q.pop();
used[x] = 0;
for(i = 1; i <= n; i++) {
if(g[x][i] == -1)
continue;
if(dis[i] > dis[x]+gv[i]+g[x][i]) {
dis[i] = dis[x]+gv[i]+g[x][i];
prev[i] = x;
if(used[i] == 0) {
used[i] = 1;
Q.push(i);
}
}
}
}
printf("From %d to %d :\n", st, ed);
int stk[105], stkidx = 0;
x = ed;
while(x != st) {
stk[stkidx++] = x;
x = prev[x];
}
printf("Path: %d", st);
for(i = stkidx-1; i >= 0; i--)
printf("-->%d", stk[i]);
if(st == ed) {
printf("-->%d", ed);
dis[ed] = gv[ed];
}
puts("");
printf("Total cost : %d\n", dis[ed]-gv[ed]);
}
if(t)
puts("");
}
return 0;
}