[UVA][sieve] 10168 - Summation of Four Primes
Problem A
Summation of Four Primes
Input: standard input
Output: standard output
Time Limit: 4 seconds
Euler proved in one of his classic theorems that prime numbers are infinite in number. But can every number be expressed as a summation of four positive primes? I don’t know the answer. May be you can help!!! I want your solution to be very efficient as I have a 386 machine at home. But the time limit specified above is for a Pentium III 800 machine. The definition of prime number for this problem is “A prime number is a positive number which has exactly two distinct integer factors”. As for example 37 is prime as it has exactly two distinct integer factors 37 and 1.
Input
The input contains one integer number N (N<=10000000) in every line. This is the number you will have to express as a summation of four primes. Input is terminated by end of file.
Output
For each line of input there is one line of output, which contains four prime numbers according to the given condition. If the number cannot be expressed as a summation of four prime numbers print the line “Impossible.” in a single line. There can be multiple solutions. Any good solution will be accepted.
Sample Input:
24
36
46
Sample Output:
3 11 3 7
3 7 13 13
11 11 17 7
Shahriar
Manzoor
“You can fool some people all the time, all the people some of the
time but you cannot fool all the people all the time.”
拆成 大於 4 的偶數,即可被兩個質數表示。
#include <stdio.h>
#define maxL (10000000>>5)+1
#define GET(x) (mark[(x)>>5]>>((x)&31)&1)
#define SET(x) (mark[(x)>>5] |= 1<<((x)&31))
int mark[maxL];
void sieve() {
register int i, j, k;
SET(1);
int n = 10000000;
for(i = 2; i <= n; i++) {
if(!GET(i)) {
for(k = n/i, j = i*k; k >= i; k--, j -= i)
SET(j);
}
}
}
void Goldbach(int n) {
if(n == 4) {
printf("2 2");
return;
}
static int i;
for(i = 3; ; i += 2) {
if(!GET(i) && !GET(n-i)) {
printf("%d %d", i, n-i);
return;
}
}
}
int main() {
sieve();
int n;
while(scanf("%d", &n) == 1) {
if(n < 8) {
puts("Impossible.");
continue;
}
if(n&1)
printf("2 3 "), n -= 5;
else
printf("2 2 "), n -= 4;
Goldbach(n);
puts("");
}
return 0;
}