[UVA][java] 10523 - Very Easy !!!
THE SAMS' CONTEST
Problem 4
VERY EASY !!! |
BACKGROUND
Most of the times, the students of Computer Science & Engineering of BUET deal with bogus, tough and very complex formulae. That is why, sometimes, even for a easy problem they think very hard and make the problem much complex to solve. But, the team members of the team "BUET PESSIMISTIC" are the only exceptions. Just like the opposite manner, they treat every hard problem as easy and so cannot do well in any contest. Today, they try to solve a series but fail for treating it as hard. Let them help.
Input
Just try to determine the answer for the following series
You are given the value of N and A (integer, 1<=N<=150 & integer, 0<=A<=15) respectively.
Output
For each line of the input, your correct program should output the integer value of the sum in separate lines for each pair of values of N & A.
Sample Input
3 3 4 4
Sample Output
102
1252
import java.math.BigInteger;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner cin = new Scanner(System.in);
int N, A;
while(cin.hasNextInt()) {
N = cin.nextInt();
A = cin.nextInt();
BigInteger ans = new BigInteger("0"), tmpA = BigInteger.valueOf(A);
for(int i = 1; i <= N; i++)
ans = ans.add(BigInteger.valueOf(i).multiply(tmpA.pow(i)));
System.out.println(ans.toString());
}
}
}