2012-06-05 22:25:16Morris

[UVA][殺人系列] 133 - The Dole Queue


 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.



模擬

#include <stdio.h>

int main() {
    int i, n, k, m;
    int next[30], pre[30];
    while(scanf("%d %d %d", &n, &k, &m) == 3) {
        if(n == 0 && k == 0 && m == 0)
            break;
        for(i = 1; i <= n; i++)
            next[i] = i+1, pre[i] = i-1;
        next[n] = 1, pre[1] = n;
        int idx1 = 1, idx2 = n, used[30] = {};
        int flag = 0;
        while(n) {
            for(i = 1; i < k; i++)
                idx1 = next[idx1];
            for(i = 1; i < m; i++)
                idx2 = pre[idx2];
            if(flag)
                putchar(',');
            flag = 1;
            if(idx1 != idx2) {
                printf("%3d%3d", idx1, idx2);
                used[idx1] = used[idx2] = 1;
                n -= 2;
                next[pre[idx1]] = next[idx1];
                pre[next[idx1]] = pre[idx1];
                next[pre[idx2]] = next[idx2];
                pre[next[idx2]] = pre[idx2];
            } else {
                used[idx1] = 1;
                printf("%3d", idx1);
                next[pre[idx1]] = next[idx1];
                pre[next[idx1]] = pre[idx1];
                n--;
            }
            if(n == 0)
                break;
            while(used[idx1])
                idx1 = next[idx1];
            while(used[idx2])
                idx2 = pre[idx2];
        }
        puts("");
    }
    return 0;
}