2012-05-12 18:24:16Morris

[UVA][Trie] 11362 - Phone List


  A: Phone List 

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

epsfbox{p11362.eps}

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input 

The first line of input gives a single integer, 1$ le$t$ le$40 , the number of test cases. Each test case starts with n , the number of phone numbers, on a separate line, 1$ le$n$ le$10000 . Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output 

For each test case, output ``YES" if the list is consistent, or ``NO" otherwise.

Sample Input 

2 
3 
911 
97625999 
91125426 
5 
113 
12340 
123440 
12345 
98346

Sample Output 

NO 
YES



做法 : Trie

題目的意思很簡單, 是否存在某個數字是另外一組數字的"前綴"

#include <stdio.h>
#include <string.h>
struct Trie {
    bool n;
    int link[10];
} Node[200000];
int TrieSize;
int insertTrie(const char *str) {
    static int i, idx;
    idx = 0;
    for(i = 0; str[i]; i++) {
        if(!Node[idx].link[str[i]-'0']) {
            TrieSize++;
            memset(&Node[TrieSize], 0, sizeof(Node[0]));
            Node[idx].link[str[i]-'0'] = TrieSize;
        }
        idx = Node[idx].link[str[i]-'0'];
        if(Node[idx].n) {
            return 1;
        }
    }
    for(i = 0; i < 10; i++)
        if(Node[idx].link[i])
            return 1;
    Node[idx].n = true;
    return 0;
}
int main() {
    int t, n;
    char str[20];
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);
        getchar();
        TrieSize = 0;
        memset(&Node[0], 0, sizeof(Node[0]));
        int flag = 0;
        while(n--) {
            gets(str);
            if(flag)
                continue;
            flag = insertTrie(str);
        }
        if(flag)
            puts("NO");
        else
            puts("YES");
    }
    return 0;
}