2012-04-02 08:07:06Morris

[UVA][Math][Stirling'sFormula] 1185 - Big Number

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input 

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 $ leq$ n $ leq$ 107 on each line.

Output 

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input 

2
10
20

Sample Output 

7
19



詳細請搜尋 Stirling's Formula
在此感謝 DJWS 提供

#include<stdio.h>
#include<math.h>
const double PI = 3.141592653589793239, e = 2.7182818284590452354;
int Stirling(int n) {
return (int)(log10(sqrt(2*PI*n)) + n*log10(n/e))+1;
}
int main() {
int DP[100001] = {0};
int t, n, i;
double last = 0;
for(i = 1; i <= 100000; i++) {
last += log10(i);
DP[i] = (int)last;
}
scanf("%d", &t);
while(t--) {
scanf("%d", &n);
if(n <= 100000)
printf("%d\n", DP[n]+1);
else
printf("%d\n", Stirling(n));
}
return 0;
}