[UVA][BFS] 572 - Oil Deposits
Oil Deposits
Oil Deposits |
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise and . Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
Sample Output
0 1 2 2
#include <stdio.h>
#include <stdlib.h>
int main() {
int n, m, i, j, k, l;
char map[101][101];
while(scanf("%d %d", &n, &m) == 2) {
if(n == 0 && m == 0)
break;
for(i = 0; i < n; i++)
scanf("%s", &map[i]);
int ans = 0, x, y, tx, ty;
int Dx[8] = {0, 0,1, 1,1,-1,-1,-1};
int Dy[8] = {1,-1,0,-1,1,0,-1,1};
for(i = 0; i < n; i++) {
for(j = 0; j < m; j++) {
if(map[i][j] == '@') {
ans++;
int Q[10000][2], Qidx = 0;
Q[0][0] = i, Q[0][1] = j;
map[i][j] = '*';
for(k = 0; k <= Qidx; k++) {
x = Q[k][0], y = Q[k][1];
for(l = 0; l < 8; l++) {
tx = x + Dx[l], ty = y + Dy[l];
if(tx >= 0 && tx < n && ty >= 0 && ty < m) {
if(map[tx][ty] == '@') {
Qidx++;
Q[Qidx][0] = tx;
Q[Qidx][1] = ty;
map[tx][ty] = '*';
}
}
}
}
}
}
}
printf("%d\n", ans);
}
return 0;
}
Great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://mcafeecomactivatenow.xyz/
great website, perfectly written content , keep up the good work and keep the good content coming, appreciate the work you put into this website. Well Researched content is always valuable. thank you https://mcafeecomactivatenow.xyz/
Positive site, where did u come up with the information on this posting? I have read a few of the articles on your website now, and I really like your style. Thanks a million and please keep up the effective work.