[UVA] 1121 - Subsequence
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
Many test cases will be given. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file. If there isn't such a subsequence, print 0 on a line by itself.
Sample Input
10 15 5 1 3 5 10 7 4 9 2 8 5 11 1 2 3 4 5
Sample Output
2 3
題目 : 找一段長度(連續)最小的總和大於等於指定值
作法 : O(n)
#include<stdio.h>
int main() {
int N, S, A[100000], i;
while(scanf("%d %d", &N, &S) == 2) {
for(i = 0; i < N; i++)
scanf("%d", &A[i]);
int tail = -1, sum = 0;
int min = 0xfffffff;
for(i = 0; i < N; i++) {
while(sum < S && tail+1 < N)
sum += A[++tail];
if(min > tail - i && sum >= S)
min = tail - i;
sum -= A[i];
}
if(min == 0xfffffff) puts("0");
else printf("%d\n", min+1);
}
return 0;
}