2011-12-16 09:22:34Morris

[UVA] 1185 - Big Number

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input 

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 $ leq$ n $ leq$ 107 on each line.

Output 

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input 

2
10
20

Sample Output 

7
19


作法 : 數學
不過速度很慢, 也不知道要怎麼改善才好, 誰能提供個意見

#include<stdio.h>
#include<math.h>
int DP[10000001] = {0};
int main() {
int t, n, i;
double last = 0;
for(i = 1; i <= 10000000; i++) {
last += log10(i);
DP[i] = (int)last;
}
scanf("%d", &t);
while(t--) {
scanf("%d", &n);
printf("%d\n", DP[n]+1);
}
return 0;
}
DJWS 2012-04-01 23:41:28

try Stirling's formula.